2019年4月20日(土) 03:16 JST

PHP-4.x系列でhtml_entity_decode()がエラー

  • 投稿者:
  • 表示回数 5,433
Geeklog

ユーザからのレポートで、 "cannot yet handle MBCS in html_entity_decode()" なるエラーが拙作のプラグインで発生しているらしい。Google先生に訊いてみると、PHP-4.xの場合、マルチバイトはサポートしていないとのこと。改めてマニュアルを読んでみると、確かにそう書いてあった。PHP-4.x系列を使わなくなって久しいので、気づかなかった。

とりあえず、Dbman, Dataproxy, Sitemap, Themeditプラグインはエラーが出ないように修正したバージョンを公開した。

タグ:dbman, dataproxy, sitemap, themedit プラグイン