2019年4月24日(水) 23:18 JST

OGP(Open Graph Protocol)プラグインv1.1.2

  • 投稿者:
  • 表示回数 1,810
プラグイン

OGPプラグインは今回の機能アップで実用に耐えるものになったと思う。改善点は

  1. 新たにリンクプラグイン、アンケートプラグイン、ファイル管理プラグイン、Downloadsプラグインをサポートした。
  2. 「いいね!」ボタンと「Facebookコメント機能」を表示するコンテンツの種類をコンフィギュレーションで設定できるようにした。

好むと好まざるとにかかわらず、FacebookやGoogle+、Twitterなどと連携できないCMSはこれから非常な苦戦を強いられるだろう。このプラグインがGeeklogを少しでも延命できれば幸いである。ダウンロードはこちらからどうぞ。

タグ:ogp

TinyMCEプラグイン-0.4.7

  • 投稿者:
  • 表示回数 1,826
プラグイン

MySQL-5.5以降でインストールに失敗していたバグを修正した。また、同梱するTinyMCEのバージョンを3.4.7に上げた。


テーマエディタプラグイン-1.2.0

  • 投稿者:
  • 表示回数 1,703
プラグイン

テーマエディタプラグイン(themedit)をGeeklog-1.6で導入された自動インストール機能に対応させた。機能追加はないが、細かなバグ修正を行っている。


サイトマッププラグイン-1.2.2

  • 投稿者:
  • 表示回数 1,612
プラグイン

懸案事項になっていたGeeklog-1.6以降の自動インストールに対応した。また、DataProxyプラグインがインストールされていない、ないし無効になっている場合にもエラーにならないようにした。


Dbmanプラグイン-0.6.0

  • 投稿者:
  • 表示回数 1,581
プラグイン

Geeklog-1.8.0に対応したDbmanプラグイン-0.6.0を公開した。主な変更点は以下の通り:

  1. 古いPHP-4.x用のコードを書き換え、PHPの警告が出ないようにした。
  2. 自動インストール時のバグを修正した。
  3. Geeklog-1.8.0で導入されたコンフィギュレーションのツールチップを表示するようにした。
  4. インストール用のドキュメントをHTML化して、admin/plugins/dbman/docsへ移動した。

なお、このバージョン0.6.0から、Geeklog-1.4.x、1.5.xには対応しなくなった。古いバージョンを使っている人は、Dbmanバージョン0.5.4を使って欲しい。

10月31日追記: バージョン0.6.0で旧バージョンからのアップグレードがうまくいかなかったバグに対応したバージョン0.6.1を公開した。機能変更はない。


タグプラグイン-0.5.4

  • 投稿者:
  • 表示回数 1,599
プラグイン

管理画面で発生していたいくつかのバグを修正した。

  1. 登録したタグを修正できなかったバグ
  2. 空白文字のみの禁止タグを登録できていたバグ
  3. 登録済みの禁止タグを重ねて登録しようとするとSQLエラーが発生するバグ
  4. チェックを入れずにタグを削除したり、禁止タグにしようとするとエラーが発生していたバグ
  5. 管理画面のHTMLが不適切であったバグ

パッチを提供していただいたYoshinori Taharaさん(dengenさん)には心から感謝いたします。